{{site.countdown.title}} Registration Now Open!
Registration
Closes In

{{days}}

DAYS

{{hours}}

HRS

{{minutes}}

MINS

{{seconds}}

SECS

Forums

Cevo client wont launch

Playing a qualifier tomorrow afternoon on Cevo, downloaded 3.0 client today and it won't even run. "Client checking for updates" "Client checking for pc issues" then the loading bar disappears I've gone through this thread http://cevo.com/forums/topic/15732/website-support/cevo-client-is-not-working-fixed-/ and was not able to find a resolution. Uninstalled every program I can think of, no firewalls/antiviruses.
Playing a qualifier tomorrow afternoon on Cevo, downloaded 3.0 client today and it won't even run. "Client checking for updates" "Client checking for pc issues" then the loading bar disappears

I've gone through this thread http://cevo.com/forums/topic/15732/website-support/cevo-client-is-not-working-fixed-/ and was not able to find a resolution. Uninstalled every program I can think of, no firewalls/antiviruses.

Posted Sunday, August 13th, 2017 5:30 AM GMT
Hello Joshie, Could you double check in your windows services for Windows Management Instrumentation if its currently running ? See image : http://mikeymurph.me/wp-content/uploads/2015/01/services_wmi.png Don't hesitate to come see us on teamspeak at ts.cevo.com if you need additional support. Thanks !
Hello Joshie,

Could you double check in your windows services for Windows Management Instrumentation if its currently running ?

See image : http://mikeymurph.me/wp-content/uploads/2015/01/services_wmi.png


Don't hesitate to come see us on teamspeak at ts.cevo.com if you need additional support.

Thanks !

Posted Sunday, August 13th, 2017 6:17 AM GMT
Oh my gosh that worked.
Oh my gosh that worked.

Posted Sunday, August 13th, 2017 6:30 AM GMT
:) Have a good day !
:)

Have a good day !

Posted Sunday, August 13th, 2017 11:08 PM GMT